JAY FIRED US!

Incident Report for Seaview

Identified

jay ate the whole server up its making my pc lag
Posted Dec 26, 2022 - 02:28 EST

Investigating

jay did not eat :O
Posted Dec 26, 2022 - 02:24 EST
This incident affects: Roblox Services (Game Systems, Join services, Roblox Status), Website, Discord Bot, User Services (Mobile App, Staff Training Portal, Page Documentation), and Discord Services (API, Group Management, Documentation, Slash Commands).